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Premastering and Mastering
An Article from Home Recording Connection - http://www.homerecordingconnection.com/
Har-Bal Tutorial

Sep 03, 2004 -
Many have asked, so let me answer here and now...with a little guidance from my buddy Earle at Har-Bal.

Many, many times in the forum people have asked me exactly why | am so amped up on We (ve Eues
Har-Bal. I answer in the typical short and to the point answers that are most effective in a forum  _ _ ,_J\
setting. | decided to write a tutorial that will give you a better look at Har-Bal and in doing so, l v i_ J

hopefully explain exactly why | sing it's praises like | do.

Why is Har-Bal Needed? =¥ I _)

to the Ears!

"Har-Bal" is an acronym (sort of) for "Harmonic Balancing". Harmonic balancing is one of the

main jobs of a mastering engineer. A recording that is harmonically balanced incorrectly makes that recording sound
different from speaker to speaker and room to room. It is this problem that is often fixed by ear. Burning a CD of your
music, listening to it on your PC, in your car on the way to work, in your home stereo, etc. Fixing problems as you find
them.

Ultimately the root cause of all these problems is an improperly balanced equalization of your final mix.

Har-Bal is essentially an equalizer unlike any typical EQ you are used to seeing. When you open a file it analyzes the
audio and displays the spectral content in a visual format that allows you to easily understand where the problems in
the audio lies.

| opened an audio file and it was analyzed by Har-Bal and displayed as shown in the image below:
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After analyzing the file, Har-Bal displays the frequency spectrum of the audio in three different "power bands":

e Yellow band - peak power spectrum
¢ Red band - the mean of the peak and average bands
e Green band - is the average EQ spectrum

You will notice that | have a significant drop at a few frequencies, one of which is around 400Hz, another at about
1.7Khz and the other is way up around 10kHz.
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These rogue resonances could be problem areas if you are playing your audio through speaker systems that either
happen to have enhanced or diminished response at those frequencies, or if they happened to be crossed over at
those frequencies.

What Har-Bal allows the engineer to do is take these peaks and valleys of the EQ spectrum and raise or lower them to
smooth out the spectrum so little nuances between speaker systems will be minimized. This is, my friends, what the
fine art of harmonic balancing is all about.

How Do I Do 1t?

Before getting in to the concepts of the application and how it all works, lets get to now the epicenter of the app, the
toolbar:
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From left to right, the buttons are as follows:

Open - used to open the audio file you wish to work with.

Print - uuuhhhh, it prints...the graph

Create New Filter - Allows the user to create a new EQ filter.

Open EQ Filter - Allows the user to open a previously saved EQ filter to use as a guide for the audio being

worked on.

Save EQ Filter - Use this button to save the current EQ filter for later use on other files.

Open Reference Track - Use this to open a reference file.

Close Reference Track - Use this to close a reference file

Swap - Use this to swap a playable reference with the current track.

Undo - Undoes the latest edit.

Redo - Redoes the last undone edit.

Stop - Stops playback

Play - Starts playback

Record - Records the track to a new file with the EQ filter applied.

Loop - loops playback to listen to the same section repeatedly.

Filter Toggle - Toggle the playback sound between filtered and unfiltered.

Reference Toggle - Toggle the reference just the same

Default Cursor Select - does nothing really...just changes the cursor back to it's default state.

Zoom In - The Zoom In command allows you to zoom in on a specific feature in the spectrum display.

Zoom Out - The Zoom Out command allows you to Zoom Out of a specific region in the spectrum display.

Pan Cursor Select - The Pan command allows you to pan the spectrum display in any direction.

Parametric EQ Cursor Select - The typical cursor which | spend most of my time with that just the basic EQing

of raising valleys and lowering peaks in the spectrum.

¢ Low Shelving Cursor Select - Use the low shelving cursor to introduce a low shelf boost or cut at a given
corner frequency with a given slope.

¢ High Shelving Cursor Select - Use the high shelving cursor to introduce a high shelf boost or cut at a given

corner frequency with a given slope.

In addition to the toolbar, there are also two faders to control volume and gain, as well as a saturation/overload
indicator and some toggle switches each of the three power bands between visible and hidden, and to toggle the
reference file as well.

Much of the work is done with the parametric EQ cursor. Click on the point that you wish to raise a lower and drag the
cursor up or down while holding down the button. You can select which band you wish to move by using the tab key on
your keyboard. | do most of my work on the green band myself, but the time will come you you will be shuttling back
and forth between them all. If you are not happy with the edit you have made, just press the escape button before
releasing the mouse button to undo it, or run through a series of undos with the undo button after the button has been
released.

If you work anything like | do, the majority of your time will be spent using the parametric EQ cursor, as this does the
bulk of the work moving up and down the valleys and peaks of the spectrum to get it nice and smooth. There are other
tools you may use from time to time. The zoom in cursor allows you to click and drag over any trouble spots to zoom
the graph in on those areas for more fine tuning. | simple "ctrl > a" or "Graph > Zoom All" will quickly bring you back to
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the default view. The pan cursor can drag the view from left to right or up and down, which could be handy if zoomed in
and needing to view a piece of the spectrum that is not currently in the graph. The High and Low Shelving cursors can
move the entire spectrum from the point of click and the highest or lowest ends of the spectrum, high shelf going to the
highest, low shelf going to the lowest, and shift that entire range of the spectrum up or down. The shelving comes in
very handy at times saving you from many clicks to raise an entire range.

The graph shown below is the spectrum after some tweaks, notice it is much smoother across the spectrum. As a
result, it will sound better from system to system, and will likely have added some power and depth to your original mix
as well. Har-Bal makes this process so much easier and quicker | almost find it threatening as a mastering engineer ;-)
This sample file, of course, could still use work beyond what is shown here, but it does illustrate my point.
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Har-Bal Har-Bal also comes bundled with a few template filters, which are handy guides to learn with, showing you the
basic spectrum of many different genre's of music for you to use as a guide to EQ your own songs. These template
filters can help you understand how each genre archives the unique sound they do by working the spectrum of the
music to achieve such a sound. | have personally found them quite interesting, and | am sure you will too.

Keyboard Shortcuts

Har-Bal also has a lot of keyboard shortcuts available for you mouse haters:

Command - Shortcut
Playback stop/start toggle - spacebar
File > Filter > Open - ctrl+ F
File > Reference > Open - ctrl+R
File > Exit - alt+F4
Edit > Undo - cirl>Z
Edit > Redo - ctrl+Y
Graph > View > Spectrum - alt+1
Graph > View > Frequency Response -at+2
Graph > View > Impulse Response - alt+3
Graph > Show Spectrum > Peak - ctrl +1
Graph > Show Spectrum > Geometric Mean - ctrl + 2
Graph > Show Spectrum > Average - ctrl+3
Graph > Show Spectrum > Original - ctrl+4

Graph > Show Spectrum > Playback Focus - ctrl + 5
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Graph > Zoom All - ctrl+ A
Equalizer > Stop - ctrl + S, spacebar
Equalizer > Play - ctrl + P, spacebar
Equalizer > Record / Record As - ctrl+D
Equalizer > Loop - ctrl+L
Equalizer > EQ In - ctrl+Q
Equalizer > Reference In - ctrl+ W
Equalizer > Match Loudness - ctrl+ M
Equalizer > Play - ctrl + P, spacebar

Loudness Matching

Ok, so you have your song or songs harmonically balanced. Groovy, but you're not done yet. The next step for the
mastering engineer is the running order of the songs of the full CD and the perceived volume going from song to song.
No listener likes to mess with the volume between songs, so the engineers job is to have a nice smooth transition from
song to song, so that both the volume and tone flows smoothly.

Loudness matching attempts to compensate for the effect of changing apparent loudness that results from equalizing.
Har-Bal does so by measuring a loudness figure for the original recording and adjusting the volume control on the
equalized version so that the loudness figure of merit after making adjustments is the same as for the original. In this
way you can be sure that the differences you hear are due to the change in spectral balance and not the change in
volume. This is the only equalizer | know of that does this in this manner, and really makes a substantial difference
when toggling the EQ to hear the difference you are making, so as not to be fooled by the volume difference, and then
be able to base your judgement on the difference in the sound.

Har-Bal makes this pretty easy with it's reference file capabilities. Open a reference file, then click the Equalizer button
in the menu bar and select Loudness Matching. What it does then is take various aspects of the reference file that
determines its perceived loudness and applies those aspects to the audio you are working on.

Use the "match loudness" feature in Har-Bal as a reference for your limiter. When using this feature, write down the
gain number. Now pull the fader back to 0.0, record the newly EQ'd file and open the limiter. Set your outceiling to -0.1
and the threshold to the number indicated by Har-Bal. If there was an increase in Har-Bal of 4.3, set the threshold for
-4.3. It works every time and the volume level is consistent throughout the entire album. This is an amazing feature in
Har-Bal. | know of no other tool that does this.

Make sure you use a reference CD for "loudness matching" that matches this genre of music.

Configuring Options

Setting up Har-Bal is quite simply really, not much to it other than selecting the driver you wish to use. Also, there is an
option "frequency tips" that can be toggled on/off. These tips are handy, but after a while they get kind of annoying and

I turn them off. For somebody just getting started though, they are quite useful in gaining an understanding of the
frequency spectrum and what frequency bands affect which parts of the overall sound.

There are also other options to change the color of the power bands, the color of the reference file bands and other
such components.

If you pay attention to the frequency tips, what your actions do to your sounds and study the template filters, Har-Bal is
really not just a useful productivity tool, but a very educational experience in the science of sound as well.

WHERE DO | BUY, WHERE DO | BUY!

If you are indeed interested in buying Har-Bal (and you should be) You can buy it through the Reg.Net link below:

@ED E-caommerce By Reg et

For more info about Har-Bal, straight from the guys that make it, go to Har-Bal.com, and check it out, ask question at
their forum (or the HRC forum) or download the 8-bit demo version.
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